Author Topic: ELECTRICAL ISSUE on Tiger 955i 2004yr  (Read 203 times)

0 Members and 1 Guest are viewing this topic.

February 11, 2020, 10:15:21 AM on

Offline cezary (OP)

  • Tiger Cub
  • Posts: 1
  • Activity Meter:
    0%
  • nOObie
  • LOCATION: London, UK
  • Bike model currently owned: Tiger Triumph 955i
ELECTRICAL ISSUE on Tiger 955i 2004yr
Hi Gang! Thanks for having me here, few months back I completed 35k km trip from Europe to SA on my Tiger 955i.   Wonder if anyone is familiar with issue  that I have on my Tiger?
 During the trip I burned stator, replaced with new pair of stator and regulator, after 5k cables between both melted, replaced with new heavy duty pair, bike is running but cables are melting, the battery got cooked. When bike runs stationary stator cover has something like 110 °C I am now in the process of replacing entire wire harness (still not sure which exact bit caused the problem). Before taking off old harness I have done following tests:
Checked all stator cables against ground (-)  - no issues.
Resistance between stator cables is 0.4 which I believe is correct
Battery V reading, bike off 12,55V, bike running 13,44V - charging is there but I think should be above 14V (?!)
4)  Checking ~V on stator when bike is running idle RPM is only 7 ~V  per cable - I think this is too low, is it?
5) Key Question:  When I measure  ~V on the stator when bike is started but stator is disconnected I get 10,5 ~V per cable, it only goes to 21-23 ~V  when I on 5k RPM. Is that correct I was under impression that ~ Voltage  on stator should be 23V all the time?

What I am trying to figure out is, is my stator / regulator healthy so when I swap harness bike is considered to be fixed?  The pair was on the road for about 5k km while riding with this issue.

Help much appreciated!

February 11, 2020, 01:34:47 PMReply #1 on

Offline Chris Canning

  • Sumatran Tiger
  • *
  • Location: Birmingham England
  • Posts: 4002
  • Activity Meter:
    0.44%
The wonders of the 955 charging system is well documented with no end of various options including the Saskatch mod so i’d Suggest trawling through the many on here.

I dug a large hole for myself trying to introduce a lithium battery after fitting a new Electrex Rectifier and had to start again minus the lithium,With a new Regulator and the RR881 Rectifier which includes the Saskatch mod so charges direct to the battery instead of going via the harness.

The only major problem I encountered when ordering such was dealing with the ladies Eastern European accent at Electrex  :icon_lol:

Currently the bike has been ticketety boo  :icon_biggrin: for some time i’m Happy to say.